樹莓派安裝Qt5的問題解決

2022-06-23 21:34:36 字數 638 閱讀 7934

e: 無法修正錯誤,因為您要求某些軟體包保持現狀,就是它們破壞了軟體包間的依賴關係【終極解決辦法】

以本人在安裝qt5-default中遇到的問題為例

sudo apt-get install qt5-default qt-sdk

依賴qtbase5-dev

sudo apt-get install qtbase5-dev

依賴libgles2-mesa-dev

sudo apt-get install libgles2-mesa-dev

。。。。。。

繼續如此操作,遇到諸如依賴libgbm1(=13.0.6-1)這樣的報錯

sudo aot-get install libgbm=13.0.6-1即可

。。。